Important changes EWS Notification obligation BA5

20 March 2017

On March 1st 2017, the new version of GMP+ BA5 Minimum requirements EWS took effect. By means of this message, we would like to alert you again to the fact that the new version of GMP+ BA5 is available.

The reason for that, is that it is important to be able to meet the EWS notification obligation and to know what changes have been implemented.

Here you can read what changes were implemented.

Click here for the new GMP+ BA5 Minimum requirements EWS.

Sign up for the GMP+ International newsletter

Stay up to date with the latest news